BACKTRACE

(condense)

Back to Posts List

GET

Tip: Installing Mysql Gem on Leopard

First, i want to make it clear that i am totally for using Oracle Express Edition, and not in Mysql, although you may need a real DBA, it is something you will want anyway, even with Mysql for my opinion.

Working with the Ruby-Based Mysql libraries is not recommended, it freezes with no prior warning in the middle of a transaction and not very stable at all for my opinion (i will update important notes from the comments if you have any other enlightenment about it).

anyway, since Leopard is running on the Intel based Macs, you’ll need to specify the ARCH flag in the gem install command.

first, make sure you installed Mysql from the official package at mysql.com

then,

<br />sudo env ARCHFLAGS="-arch i386" gem install mysql -- --with-mysql-config=/usr/local/mysql/bin/mysql_config<br />

Imporatant!!!! make sure you update your XCode libraries from the Leopard CDs.

POST

blog comments powered by Disqus

I Don't have cookies.

ELAD ENV

Variable Value
LINKEDIN
TWITTER
FACEBOOK
GITHUB
WWR
IRC
{ 'irc.freenode.net' => [ '#rubyonrails', '#railsbridge', '#ruby', '#mootools' ]}
SKYPE
eladmeidar

You're seeing this error because I think it is funny.